| # Uncomment this to turn on verbose mode. |
| ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
| # On PowerPC we compile against the hand-crafted assembly, on all |
| # other architectures we compile against GPL'ed sha1 code lifted |
| # from Mozilla. OpenSSL is strangely licensed and best avoided |
| HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH) |
| ifeq (${HOST_ARCH},powerpc) |
| export PPC_SHA1=YesPlease |
| export MOZILLA_SHA1=YesPlease |
| MANDIR := /usr/share/man/ |
| DESTDIR := $(CURDIR)/debian/tmp |
| DOC_DESTDIR := $(DESTDIR)/usr/share/doc/git-core/ |
| MAN_DESTDIR := $(DESTDIR)/$(MANDIR) |
| build: debian/build-stamp |
| $(MAKE) prefix=$(PREFIX) all doc |
| make DESTDIR=$(DESTDIR) prefix=$(PREFIX) mandir=$(MANDIR) \ |
| find $(DOC) '(' -name '*.txt' -o -name '*.html' ')' -exec install {} $(DOC_DESTDIR) ';' |
| find debian/tmp -type d -o -print | sed -e 's/^/? /' |
| binary-arch: build install |
| binary-indep: build install |
| binary: binary-arch binary-indep |
| .PHONY: build clean binary install clean debian-clean |