blob: 41c33b7acbd6433f6f7b5efb1f652b2e271d89c9 [file] [log] [blame]
From 2f82c9aa6af54241171a339ab9814f67dc9813df Mon Sep 17 00:00:00 2001
From: Junio C Hamano <junio@pobox.com>
Date: Wed, 26 Jul 2017 10:24:20 -0700
Subject: connect: reject ssh hostname that begins with a dash
When commands like "git fetch" talk with ssh://$rest_of_URL/, the
code splits $rest_of_URL into components like host, port, etc., and
then spawns the underlying "ssh" program by formulating argv[] array
that has:
- the path to ssh command taken from GIT_SSH_COMMAND, etc.
- dashed options like '-batch' (for Tortoise), '-p <port>' as
needed.
- ssh_host, which is supposed to be the hostname parsed out of
$rest_of_URL.
- then the command to be run on the other side, e.g. git
upload-pack.
If the ssh_host ends up getting '-<anything>', the argv[] that is
used to spawn the command becomes something like:
{ "ssh", "-p", "22", "-<anything>", "command", "to", "run", NULL }
which obviously is bogus, but depending on the actual value of
"<anything>", will make "ssh" parse and use it as an option.
Prevent this by forbidding ssh_host that begins with a "-".
Noticed-by: Joern Schneeweisz of Recurity Labs
Reported-by: Brian at GitLab
Signed-off-by: Junio C Hamano <gitster@pobox.com>
Reviewed-by: Jeff King <peff@peff.net>
Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
connect.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/connect.c b/connect.c
index 8cb93b0720..27dafb48cf 100644
--- a/connect.c
+++ b/connect.c
@@ -791,6 +791,9 @@ struct child_process *git_connect(int fd[2], const char *url,
return NULL;
}
+ if (ssh_host[0] == '-')
+ die("strange hostname '%s' blocked", ssh_host);
+
ssh = get_ssh_command();
if (!ssh) {
const char *base;
--
2.14.0.434.g98096fd7a8