blob: 3429abd4cc0b12b24b84f052386002692b5e2e9c [file] [log] [blame]
From fb73c3a26454bb024d05f63dd6bd0f11f09bae3d Mon Sep 17 00:00:00 2001
From: Jeff King <peff@peff.net>
Date: Thu, 29 Aug 2019 13:43:23 -0400
Subject: t9300: create marks files for double-import-marks test
Our tests confirm that providing two "import-marks" options in a
fast-import stream is an error. However, the invoked command would fail
even without covering this case, because the marks files themselves do
not actually exist. Let's create the files to make sure we fail for the
right reason (we actually do, because the option parsing happens before
we open anything, but this future-proofs our test).
Signed-off-by: Jeff King <peff@peff.net>
(cherry picked from commit 816f806786e12435163c591942a204c5a3bdd795)
Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
---
t/t9300-fast-import.sh | 2 ++
1 file changed, 2 insertions(+)
diff --git a/t/t9300-fast-import.sh b/t/t9300-fast-import.sh
index 8621eb3889..f79fcf4c1e 100755
--- a/t/t9300-fast-import.sh
+++ b/t/t9300-fast-import.sh
@@ -2107,6 +2107,8 @@ test_expect_success 'R: abort on receiving feature after data command' '
'
test_expect_success 'R: only one import-marks feature allowed per stream' '
+ >git.marks &&
+ >git2.marks &&
cat >input <<-EOF &&
feature import-marks=git.marks
feature import-marks=git2.marks
--
2.24.0.393.g34dc348eaf