| From 0329acb1aa4444da4ee1007674c469c2e63dcf48 Mon Sep 17 00:00:00 2001 |
| From: Elijah Newren <newren@gmail.com> |
| Date: Tue, 7 Apr 2020 16:59:23 +0000 |
| Subject: sequencer: honor GIT_REFLOG_ACTION |
| |
| commit 1f6965f994f8fe2fca80e17b5dbb293d05716be9 upstream. |
| |
| There is a lot of code to honor GIT_REFLOG_ACTION throughout git, |
| including some in sequencer.c; unfortunately, reflog_message() and its |
| callers ignored it. Instruct reflog_message() to check the existing |
| environment variable, and use it when present as an override to |
| action_name(). |
| |
| Also restructure pick_commits() to only temporarily modify |
| GIT_REFLOG_ACTION for a short duration and then restore the old value, |
| so that when we do this setting within a loop we do not keep adding " |
| (pick)" substrings and end up with a reflog message of the form |
| rebase (pick) (pick) (pick) (finish): returning to refs/heads/master |
| |
| Signed-off-by: Elijah Newren <newren@gmail.com> |
| Signed-off-by: Junio C Hamano <gitster@pobox.com> |
| Signed-off-by: Jonathan Nieder <jrnieder@gmail.com> |
| --- |
| sequencer.c | 10 ++++++++-- |
| t/t3406-rebase-message.sh | 16 ++++++++-------- |
| 2 files changed, 16 insertions(+), 10 deletions(-) |
| |
| diff --git a/sequencer.c b/sequencer.c |
| index e528225e787..24a62d5aa5d 100644 |
| --- a/sequencer.c |
| +++ b/sequencer.c |
| @@ -3708,10 +3708,11 @@ static const char *reflog_message(struct replay_opts *opts, |
| { |
| va_list ap; |
| static struct strbuf buf = STRBUF_INIT; |
| + char *reflog_action = getenv(GIT_REFLOG_ACTION); |
| |
| va_start(ap, fmt); |
| strbuf_reset(&buf); |
| - strbuf_addstr(&buf, action_name(opts)); |
| + strbuf_addstr(&buf, reflog_action ? reflog_action : action_name(opts)); |
| if (sub_action) |
| strbuf_addf(&buf, " (%s)", sub_action); |
| if (fmt) { |
| @@ -3799,8 +3800,11 @@ static int pick_commits(struct repository *r, |
| struct replay_opts *opts) |
| { |
| int res = 0, reschedule = 0; |
| + char *prev_reflog_action; |
| |
| + /* Note that 0 for 3rd parameter of setenv means set only if not set */ |
| setenv(GIT_REFLOG_ACTION, action_name(opts), 0); |
| + prev_reflog_action = xstrdup(getenv(GIT_REFLOG_ACTION)); |
| if (opts->allow_ff) |
| assert(!(opts->signoff || opts->no_commit || |
| opts->record_origin || opts->edit)); |
| @@ -3845,12 +3849,14 @@ static int pick_commits(struct repository *r, |
| } |
| if (item->command <= TODO_SQUASH) { |
| if (is_rebase_i(opts)) |
| - setenv("GIT_REFLOG_ACTION", reflog_message(opts, |
| + setenv(GIT_REFLOG_ACTION, reflog_message(opts, |
| command_to_string(item->command), NULL), |
| 1); |
| res = do_pick_commit(r, item->command, item->commit, |
| opts, is_final_fixup(todo_list), |
| &check_todo); |
| + if (is_rebase_i(opts)) |
| + setenv(GIT_REFLOG_ACTION, prev_reflog_action, 1); |
| if (is_rebase_i(opts) && res < 0) { |
| /* Reschedule */ |
| advise(_(rescheduled_advice), |
| diff --git a/t/t3406-rebase-message.sh b/t/t3406-rebase-message.sh |
| index 61b76f33019..927a4f4a4e4 100755 |
| --- a/t/t3406-rebase-message.sh |
| +++ b/t/t3406-rebase-message.sh |
| @@ -89,22 +89,22 @@ test_expect_success 'GIT_REFLOG_ACTION' ' |
| git checkout -b reflog-topic start && |
| test_commit reflog-to-rebase && |
| |
| - git rebase --apply reflog-onto && |
| + git rebase reflog-onto && |
| git log -g --format=%gs -3 >actual && |
| cat >expect <<-\EOF && |
| - rebase finished: returning to refs/heads/reflog-topic |
| - rebase: reflog-to-rebase |
| - rebase: checkout reflog-onto |
| + rebase (finish): returning to refs/heads/reflog-topic |
| + rebase (pick): reflog-to-rebase |
| + rebase (start): checkout reflog-onto |
| EOF |
| test_cmp expect actual && |
| |
| git checkout -b reflog-prefix reflog-to-rebase && |
| - GIT_REFLOG_ACTION=change-the-reflog git rebase --apply reflog-onto && |
| + GIT_REFLOG_ACTION=change-the-reflog git rebase reflog-onto && |
| git log -g --format=%gs -3 >actual && |
| cat >expect <<-\EOF && |
| - rebase finished: returning to refs/heads/reflog-prefix |
| - change-the-reflog: reflog-to-rebase |
| - change-the-reflog: checkout reflog-onto |
| + change-the-reflog (finish): returning to refs/heads/reflog-prefix |
| + change-the-reflog (pick): reflog-to-rebase |
| + change-the-reflog (start): checkout reflog-onto |
| EOF |
| test_cmp expect actual |
| ' |
| -- |
| 2.26.0.110.g2183baf09c |
| |